Question about project 4

The Experimenters Kit includes an "Eleven" Arduino-compatible board, plus a range of parts and a guide to make it easy to get started with Arduino projects. [Product Page]
Post Reply
Joined:Thu Feb 20, 2014 6:05 am
Question about project 4

Post by whirlybomber » Thu Feb 20, 2014 6:18 am


Just got a FreeTronics experimenter kit the other day, been playing with it for a lttle bit and I was up to example 4 in the handbook.

So I built the circut on the breadboard and copied the code from the freetronics webpage but something went Boink! during uploading the sketch.

So now the on-board TX led is flashing constantly, and when I try and upload and sketch I get something like the following in the panel at the bottom of the IDE:
Arduino error 2014 02 20.png
screen capture of IDE with error message
This occurs even after I disconnect the Eleven from USB and close the IDE then count to ten, reopen and reconnect.

How have I Borked the board so quickly, and is it possible to un-Bork it?


After reading viewtopic.php?f=3&t=5796 I edit to add I am on Ubuntu 12.04LTS and I am using the IDE v 1.0.5 already.

Freetronics Staff
Freetronics Staff
Joined:Wed Nov 09, 2011 12:53 am

Re: Question about project 4

Post by cef » Thu Feb 20, 2014 9:33 pm

Looks like the board isn't at /dev/ttyACM0 anymore.

From a command prompt, look at the output of the 'dmesg' command. It will list all the devices found (in order) and in there you may see something referring to /dev/ttyACM0 or some other number (eg: ttyACM1). Whatever the last one is, change the setting in the IDE to match.

Note: The usual reason for this is that the OS hasn't removed the old device before it's being presented with a new one (by the USB subsystem). Sometimes you can get away with just unplugging it and then plugging it back in again, but sometimes it wants to hold onto your device forever (usually depends on exactly what was going on when it was unplugged).

If dmesg says the device should be /dev/ttyACM0, then you may find that something else is using it. Specifically, networkmanager on Ubuntu (and variants) tends to think these devices are modems. You may need to tell network manager to leave the device alone. I remember there being some details on this for the LeoSticks, but I didn't think it affected the Eleven.

PS: Another useful tool is 'lsusb', which will show you what devices are connected (includes the "root hubs" that are on the motherboard, etc). More detailed info can be provided using 'lsusb -v', but hopefully you won't need to look that deep.

Joined:Thu Feb 20, 2014 6:05 am

Re: Question about project 4

Post by whirlybomber » Fri Feb 21, 2014 5:07 am

So I tried lsusb without the Eleven plugged in then with it plugged in:
Eleven showing up in lsusb.png
Then I looked at it in lsusb -v. I dunno what any of this means.
Eleven showing up as last entry in lsusb -v.png
So it looks like Ubuntu is seeing the Eleven when plugged in and then releasing it when unplugged.

Next I opened the Arduino IDE and looked to see if it was in Tools -> Serial Port, and it is there as /dev/ttyACM0.

Then I tried uninstalling the IDE and reinstalling it. But as soon as you try to write to it it goes grey, and you get a big pile of error messages.
  Turns on an LED on for one second, then off for one second, repeatedly.
  This example code is in the public domain.

void setup() {
  // initialize the digital pin as an output.
  // Pin 13 has an LED connected on most Arduino boards:
  pinMode(13, OUTPUT);

void loop() {
  digitalWrite(13, HIGH); // set the LED on
  delay(1000); // wait for a second
  digitalWrite(13, LOW); // set the LED off
  delay(1000); // wait for a second
This is the bit of the error message with the red in it. I had to crop off the RHS of the white text to get the file size down. For some unkown reaso although you can highlight the this text in the IDE you cannot copy or past it as text, hence the screenshot.
Screenshot from 2014-02-21part1.png
Any further ideas?

Billy the Beagle
Joined:Fri Jan 09, 2015 5:31 am

Re: Question about project 4

Post by Billy the Beagle » Sat Jan 10, 2015 1:15 pm

I experienced this problem also. I am running a Ubuntu derivative (LXLE) on my netbook. This problem has been discussed on the ask Ubuntu forums

here ... ontroller
and here ... 122#58122
I tried the suggested method of adding myself to the dialout group, but that did not fix the problem.

What did work was one of the other suggestions on the first link - closing down all instances of the arduino IDE, then editing the arduino preferences.txt file (~/arduino/preferences.txt), looking for the Serial.debug_rate, and changing it to 9600. I think 9600 baud is the default value for the serial monitor.

This will allow the IDE to connect with the serial port, and the serial monitor will work fine.

If you run the sketch as shown in the guide, the problem will re-occur though.

I closed the IDE down and edited the preferences.txt to set the Serial.debug_rate to 9600. Then I loaded the sketch and changed this line




The sketch compiled and uploaded fine with no serial port issues, and worked well. I opened the serial monitor and the messages showing the light level values came through as expected - and reasonably quickly too. Changing the baud rate from 38400 back to 9600 did not seem to impact much for showing human readable text.

Earlier I had tried shutting the computer down and plugging the arduino in to another usb port, but this just caused the same problem on the other usb port.

For some reason setting the serial port rate to 38400 causes this problem - not sure if this is limited to Ubuntu, or whether other (non-buntu) linux and windows have similar problems.

Post Reply