Issues with special characters

The Experimenters Kit includes an "Eleven" Arduino-compatible board, plus a range of parts and a guide to make it easy to get started with Arduino projects. [Product Page]
dkny
Posts: 2
Joined: Tue Dec 27, 2016 6:45 am

Issues with special characters

Postby dkny » Tue Dec 27, 2016 6:50 am

Hi there all,

I bought my son an experimenters kit, but some of the projects get a stray \302 error.

I tried using the Fix Encoding and reload, and I can see the problem....spaces are being replaced by special characters...see below

If I delete them all, the code compiles fine. I tried on an old XP windows machine and it works fine. But on my windows 10 I always get these special characters...

any ideas?
Thanks,
Darren.

void setup() {
  for (int thisLed = 0; thisLed < ledCount; thisLed++) {
    pinMode(ledPins[thisLed], OUTPUT);
  }
  pinMode(buttonPin, INPUT);
}

void loop() {
  for (int thisLed = 0; thisLed < ledCount-1; thisLed++) {
    digitalWrite(ledPins[thisLed], HIGH);
    delay(ledDelay);
    while(digitalRead(buttonPin) == HIGH) {
      delay(10);
    }
    digitalWrite(ledPins[thisLed], LOW);
  }
}

dkny
Posts: 2
Joined: Tue Dec 27, 2016 6:45 am

Re: Issues with special characters

Postby dkny » Tue Dec 27, 2016 10:15 am

Ok - just in case anyone else has this problem, i fixed it by setting the language to English UK (rather than accept operating system default) in preferences (File -> Preferences).

cholmes
Posts: 3
Joined: Sat Feb 11, 2017 4:01 am

Re: Issues with special characters

Postby cholmes » Sat Feb 11, 2017 4:07 am

It is better to copy the code from the "Experimenters Kit Example Sketches" web page rather than the pdf...
http://www.freetronics.com/pages/experi ... e-sketches

appytech
Posts: 1
Joined: Tue Mar 14, 2017 11:07 am

Re: Issues with special characters

Postby appytech » Fri Mar 17, 2017 5:59 am

dkny thanks for that info very useful.


Return to “Experimenters Kit”

Who is online

Users browsing this forum: No registered users and 1 guest