Page 2 of 2

Re: Freetronics AVRISP programmer

Posted: Thu Nov 28, 2013 8:28 pm
by vero96
Hi Angus,

Well I "think" I finally have installed Zadig correctly The trick seemed to be Click on -->Device -->Create new device --> then type USBasp into the top of the drop down menu hit Enter --> click the drop down arrow and the USBasp is found it --> click install driver --> will it will then install.

Hope that helps someone else! Windoze 8 sux :evil: I'm going to have to learn to use my Linux box :D more GUI's make me Lazy lol

Now I seem to have a problem with eXtreame burner after downloading ver 1.4.1 ( because v1 would not work ) v1.4.1 it makes it all the way through the install then immediately gives a ARVprog.exe - System error - message telling me The program can't start because libusb0.dll is missing from your computer. Try reinstalling the program to fix the problem. ( which I have done several time / taken the windoze OS advise to no avail. I have also looked in --> Computer --> OS (C:\) --> Program files --> Extreame burner - AVR --> driver --> ai64 --> and the libusb0.dll file is there! ???

So the .dll is on the system it just can't seem to see it! any thoughts? ( other than microsoft sux ) That .dll file is the one for ver 1.4.1 by the way, so I'm at a loss - uninstalling extreamburner ver. 1 does not help either same result as above when I try a re-install of ver 1.4.1 which I have uninstalled prior to attemping a re-install.

Any thoughts or ideas always appreciated

Cheers, Vero

Re: Freetronics AVRISP programmer

Posted: Tue Dec 03, 2013 8:19 pm
by vero96
*bump*

So I was incorrect in what I wrote in regard to extreamburner
Now I seem to have a problem with eXtreame burner after downloading ver 1.4.1 ( because v1 would not work ) v1.4.1 it makes it all the way through the install then immediately gives a ARVprog.exe - System error - message telling me The program can't start because libusb0.dll is missing from your computer. Try reinstalling the program to fix the problem. ( which I have done several time / taken the windoze OS advise to no avail. I have also looked in --> Computer --> OS (C:\) --> Program files --> Extreame burner - AVR --> driver --> ai64 --> and the libusb0.dll file is there! ???
the libusb0.dll file I was finding was for ver 1 , However with the win 8 pro OS when one goes to "apps" ver 1.4.1 is detected and tries to launch to unsuccessfully.

I uninstalled ver 1.4.1 and reinstalled ver 1 it will now launch ( however it is not displayed under "apps" and you have to look in --> Computer --> OS (C:\) --> Program files --> Extreame burner - AVR to launch it.

Problem being extreamburner does not detect the USBasp Programmer regardless of weather the target is connected or not.

I have done some searches and there are others with this problem it may be that the program is not compatible with win8 pro or driver signing needs to be disabled. I was unable to find the certificate.

If any one knows how to a. find the certificate and b. disable driver signing that would be a great help, I did follow the guide to disabling driver signing angus linked in an earlier post, however when I went in to the BIOS there was nothing I could find to do so options wise. There must be a way to get extreamburner working on a win8pro machine.

Cheers vero

Re: Freetronics AVRISP programmer

Posted: Wed Dec 04, 2013 5:53 am
by angusgr
Hi vero,

Sorry to hear it's not cooperating. I'm afraid I can't give any more advice except to try and find more information for how to disable driver signature verification on your particular Windows setup.

- Angis

Re: Freetronics AVRISP programmer

Posted: Fri Jan 03, 2014 1:49 pm
by vero96
Hi angus,

Still haven't been able to get zadig going.
try and find more information for how to disable driver signature verification on your particular Windows setup.



...did that, no difference I managed to get the work done on an XP so the USBasp did its job and the fact it provides the target power is a bonus! when I get it working on the desired machine win8pro I'll post how I did it to help other's.....I think it's a win8 thing....


Cheers vero

Re: Freetronics AVRISP programmer

Posted: Wed Sep 10, 2014 1:06 pm
by vero96
How I got it to work - followed this tutorial http://letsmakerobots.com/node/36841 on another machine (which helps) disabled the signature verification process. Worked perfectly first time I was able to read a few atmega8's on the win 8 machine. Thanks to everyone who helped, I must have been doing something wrong but swear I wasn't so..... what I think helped was a fresh download of zadig and started from scratch.

Cheers Vero :D