Line running down OLED

128x128 pixel 1.5" full colour OLED display with MicroSD card slot. [Product page]
Post Reply
Geoffro
Posts: 10
Joined: Fri Sep 06, 2013 1:24 am
Location: Sydney, Australia
Contact:

Line running down OLED

Post by Geoffro » Sun Sep 08, 2013 7:40 am

Hi, just bought 2 of these for a project I am doing, but one of them has a thick bar running down the screen. When full colours are displayed, it shows as a dark wide bar running from top to bottom, and when its say.. white text on black, you see a cyan wide bar running through the text.

Who should I contact to replace this OLED panel, you guys or the supplier? the other one works just fine.

angusgr
Freetronics Staff
Freetronics Staff
Posts: 853
Joined: Tue Apr 09, 2013 11:19 pm
Location: Melbourne, Australia
Contact:

Re: Line running down OLED

Post by angusgr » Sun Sep 08, 2013 10:24 am

Sorry to hear that it's defective.

It's up to you where you return it, either option is possible. If you decide to return it to us directly, just drop us a line support@freetronics.com and we'll work it out. Of course it may be more convenient to go through the retailer.

- Angus

Geoffro
Posts: 10
Joined: Fri Sep 06, 2013 1:24 am
Location: Sydney, Australia
Contact:

Re: Line running down OLED

Post by Geoffro » Mon Sep 09, 2013 7:38 am

Thanks Angus, yeah will probably be return to you, it's a fair drive for me to return it to the store I bought it from as I had to find one that actually had them in stock, probably will order direct from you guys from now on, you are alot more helpful than the retailer.

Just as an addition and for anyone who might experience the same thing and ask themselves if it's normal, no this is not normal :D

I apologise for the photos, this is one hard sucker to get a photo of...

(diagonal lines are of course refresh rate camera problems, not the LCD, its the fat straight vertical line that is the culprit)

Very visible on solid colours

Image
Image

And on text, this is blue cyan discoloration I mentioned...

Image

Things
Posts: 36
Joined: Mon Aug 26, 2013 3:47 pm
Location: Cairns, Australia
Contact:

Re: Line running down OLED

Post by Things » Sun Sep 29, 2013 1:51 am

Try very carefully disconnecting the OLED ribbon cable and plugging it back in. I had a line down mine too but reseating the ribbon cable fixed it.

angusgr
Freetronics Staff
Freetronics Staff
Posts: 853
Joined: Tue Apr 09, 2013 11:19 pm
Location: Melbourne, Australia
Contact:

Re: Line running down OLED

Post by angusgr » Sun Sep 29, 2013 11:37 pm

Thanks for the tip, Things!

Post Reply