FATAL: Module g2d_23 not found.? Raspberry pi

128x128 pixel 1.5" full colour OLED display with MicroSD card slot. [Product page]
Post Reply
fythatthep3
Posts: 2
Joined: Tue Jun 17, 2014 3:17 pm

FATAL: Module g2d_23 not found.? Raspberry pi

Post by fythatthep3 » Tue Jun 17, 2014 3:26 pm

I use OLED128 Display with Raspberry pi when I command FRAMEBUFFER=/dev/fb1 startx
i see FATAL: Module g2d_23 help me TOT

Build Date: 18 December 2013 05:20:52PM
xorg-server 2:1.12.4-6+deb7u2 (Julien Cristau <jcristau@debian.org>)
Current version of pixman: 0.29.3
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Jun 17 15:11:47 2014
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
FATAL: Module g2d_23 not found.

angusgr
Freetronics Staff
Freetronics Staff
Posts: 853
Joined: Tue Apr 09, 2013 11:19 pm
Location: Melbourne, Australia
Contact:

Re: FATAL: Module g2d_23 not found.? Raspberry pi

Post by angusgr » Tue Jun 17, 2014 10:18 pm

Hi fythatthep,

The "g2d_23" message is actually harmless, despite the "FATAL" statement to the contrary! The Pi prints it every time xorg (the X display server) loads:
http://www.raspberrypi.org/forums/viewt ... 66&t=67334

Does the display work? Does the program keep running or does it exit immediately?

The log file /var/log/Xorg.0.log may contain more details if it is not working properly.

(If pasting the contents of that file, please click the "Code" button above the editor to place "code" tags around it so it is formatted correctly.)

Regards,


Angus

fythatthep3
Posts: 2
Joined: Tue Jun 17, 2014 3:17 pm

Re: FATAL: Module g2d_23 not found.? Raspberry pi

Post by fythatthep3 » Tue Jun 24, 2014 5:11 pm

Thanks a lot :)
I Can use it
- sudo nano /usr/share/X11/xorg.conf.d/99-fbturbo.conf Option
"fbdev" "/dev/fb0" I changed from 0 to 1

angusgr
Freetronics Staff
Freetronics Staff
Posts: 853
Joined: Tue Apr 09, 2013 11:19 pm
Location: Melbourne, Australia
Contact:

Re: FATAL: Module g2d_23 not found.? Raspberry pi

Post by angusgr » Tue Jun 24, 2014 9:58 pm

Glad you got it working properly. :)

harada57
Posts: 4
Joined: Sun Aug 06, 2017 3:38 am

Re: FATAL: Module g2d_23 not found.? Raspberry pi

Post by harada57 » Sun Aug 06, 2017 8:45 am


Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests