Page 1 of 2

USB Driver

Posted: Thu Aug 22, 2013 2:36 am
by niels
It took me a little while to find a USB driver for the goldilocks -- including it here for others.

Re: USB Driver

Posted: Tue Aug 27, 2013 9:22 am
by IanK
Hi guys,
I've just received my Goldilocks and have installed the IDE and am able to see the two versions of Goldilocks in the tools drop down menu. I am however unable to install the .inf driver. When I open device manager and see Goldilocks under other devices and select to update the driver the wizard tells me that the hardware was not installed because the wizard could not find the necessary software. I have downloaded the file from freetronics.com/usbdriver as the file and the zip.file as well as the one attached in the post above and the end result is the same. I have two other boards, the uno and fretronics etherten and in both cases these work fine. I have attached a .txt file showing the log of events during the update process, this file is located in the Windows folder.
Any assistance would be much appreciated.....on a positive note the loaded sketch on the Goldilocks works but boy are those LED's bright :D

Re: USB Driver

Posted: Tue Aug 27, 2013 10:16 am
by IanK
After posting above I gave the install a couple of more tries and found that the ini file FreetronicsUSB_V1_3.inf does not seem to work, at least for me. If I remove all instances of this file from my PC and use the benito.inf file it works a treat. I have been able to upload and run the sample RTC code as a test. :D :D

Re: USB Driver

Posted: Tue Aug 27, 2013 11:49 pm
by niels
Hi Ian,

When you install the driver, you need to select 'Browse my computer for driver software' and select the folder containing the .inf file.

This file actually uses an existing driver that ships with Windows (usbser.sys, which should exist in c:\windows\system32\drivers). You won't have to specify this location, but I'm mentioning it here because you may be prompted with a security warning when installing the driver.

If the above doesn't help you, can you please let me know exactly what version of Windows you're using, and if the usbser.sys file exists in the directory above.

Thanks,
Niels

Re: USB Driver

Posted: Wed Aug 28, 2013 7:37 am
by IanK
Hi Niels,
Thanks for your reply. Everything is working now using your driver. What had originally happened was that I downloaded the freetronics driver and saved it to my USB memory stick when I browsed to it and tried to load it nothing happened. I then downloaded your driver and saved it to the same memory stick so there were two inf. files on it and again it wouldnt work, :roll: when I removed the freetronics one and only had yours, the benito one, everything worked fine.
Thanks for your help. :D :D

Re: USB Driver

Posted: Sun Oct 06, 2013 1:40 am
by stryker
Hi guys

Does the retail version of Goldilocks still have the same "Getting Started with Goldilocks" page in the pack as the Pozible ones? If so, to eliminate this recurring issue it's probably worth hosting the .inf above at http://www.freetronics.com/usbdriver since step#1 on that page sends you there.

Cheers !
Geoff

Re: USB Driver

Posted: Tue Dec 17, 2013 6:01 pm
by aeroduino
I am also having trouble installing the usb driver :(

I tried three different ones and noone is accepted. I do have the usbser.sys in the directory mentioned above..

Any help?

Using Win7 Pro SP1, 64-bit

Re: USB Driver

Posted: Wed Dec 18, 2013 4:24 pm
by aeroduino
hmm... after checking the below, I changed hardware id in the inf file and it installed but now I get a "cannot start device code 10".... :x

Image

Re: USB Driver

Posted: Wed Dec 18, 2013 10:07 pm
by andrew
If you are using Windows, you will need obtain a INF file for the USB Serial interface. As the standard LUFA USB nonclamenture is used, the LUFA U2duino.INF found in the production_firmware folder of the Goldilocks 20130818 file should be installed.

http://feilipu.files.wordpress.com/2013 ... 130818.zip

From the Goldilocks Manual, link from:
http://www.freetronics.com/collections/ ... a1284p-mcu

Re: USB Driver

Posted: Thu Dec 19, 2013 5:20 am
by aeroduino
I tried three different inf files, one was the the you suggest. Does not work