Page 2 of 2

Re: Goldilocks support

Posted: Mon Sep 09, 2013 2:10 am
by techydude
feilipu wrote: I use a terminal that has history, so use the up arrow or similar to get the !!! ready, then the right technique is to hold thumb on 1284p reset and finger on Enter with that !!! already typed. That should get the best success.
Your recommended term app requires compilation (sigh - don't get me started on that - hopefully one day soon I can qualify for membership amongst the users of software made by eliteist wankgroup devs who never post binaries even for the most obvious/common platforms, even if having a 'reference build' based on specific compiler settings would make tech-spport-minimisation sense for all concerned), so the one i'm using doesn't have history.

but, on the times when i've been successful, it wasn't when I was being particularly 'tight' in my execution of the reset/!!! sequence. I *think* I've done it enough times with various human-scale timings & observed the onboard LED enough to have a reasonable sense that it's not a simple time-out of the bootloader, especially when sometimes it'll sit there waiting, not executing the sketch, but seemingly deaf.
feilipu wrote:The "Chip Erase delay" that you caught is referred to in my blog, along with how to fix it in Step 3.
yeah i found that late last night after i'd posted back here ;)
but as you say, i don't think we're at that stage yet. but once i am, i'll poke around there to see if it still seems to be necessary.
feilipu wrote:Let's keep at it. Might be an underlying issue that you're exposing.
I just 'installed' Arduino 1.0.5 onto an older Macbook Pro which has zero install history for any of this stuff, pointed the Sketch folder to my Dropbox where the additional hardware/boards.txt etc stuff is already located, loaded the Blink sketch, it found Goldilocks as an available board type & I selected it & the correct tty port for the blink sketch, but got exactly the same results as originally posted.

so then I set the Sketch folder back to the default ~/Documents/Arduino folder, & copied the Goldilocks-22 folder into ~Documents/Arduino/hardware, and.... it worked! And it worked a 2nd time without any zero-power-resetting! Hmmmm.

So I'll play around with my original Arduino setup & try to isolate things to see what the cause is...

However, a few rolls of WS2812B & a 5V/150W PSU just arrived this morning, so it may be a few days ;)


Re: Goldilocks support

Posted: Sun Sep 22, 2013 5:42 am
by techydude
Hi guys,
Sorry for being so uncommunicado lately, been tied up with other things. But will have time to look at Goldilocks again this week.

Re: Goldilocks support

Posted: Fri Jan 24, 2014 3:01 pm
by richard47
I have found that Goldilocks is incompatible with the freetronics ASK Receiver Shield.

When the shield is attached the incoming data does not appear on D8. However, an attached oscilloscope shows data on D8 when the Reset button on the shield is pressed!

My Goldilocks has spent most of its life in a cupboard as I have been beset with the lack of compatibility with shields that work with an Arduino Uno and freetronics EtherTen.

For instance my Goldilocks is not compatible with my Arduino Ethernet Shield.

Any thoughts?

Re: Goldilocks support

Posted: Thu Jan 30, 2014 10:25 pm
by feilipu

can you define the incompatibility with the Ethernet Shield that you're describing?

I'm using some standard Ethernet Shields (and the Freetronics Shield is a "standard" one), with no problems. In fact, Ethernet is one of the key justifications for using a Goldilocks.

Regards, Phillip

Re: Goldilocks support

Posted: Tue Oct 13, 2015 9:34 pm
by q2dg
I think a good idea could be adding Goldilocks to official Arduino's Boards Manager.

Re: Goldilocks support

Posted: Tue Nov 10, 2015 11:04 pm
by feilipu
The bootloader timeout is too short for some machines, so I made it 4x as long as previously.
The bootloader will flash the LED several times before launching the installed application.
In the Arduino IDE if you type !!! into the serial monitor set on 38,400 baud and only hit "Send" when the LED is flashing, then you will get into the boot monitor.

Goldilocks Bootloaders 20151111