Page 2 of 2

Re: Cube4 Compiler Error/ Missing Driver /Windows8 / IDE 1.0

Posted: Thu Jun 27, 2013 2:09 am
by angusgr
BiggusD wrote:It seems to be the compiler dosent recognise what a cube is, so does the compiler look at the drivers? Or does installing new drivers affect the compiler bit of the program
Or am i getting confused because sometimes i feel like my brain dosent get enough blood supply for some reason
Anything's confusing when it's new and unfamiliar. It does lessen over time, I promise... :)

Compiler errors like "cube does not name a type" don't refer to the drivers, the cube here is part of the Cube library rather than the actual device. To confirm this, click the Tick button ("Verify") in the Arduino IDE and check you get the same error as when you click the Arrow button ("Upload"). The verify step doesn't care what you have plugged in, it just tries to compile the source code yu have loaded in the window.

Can you go through the following steps and post the full verbose compiler output, please?
angusgr wrote:please go to File -> Preferences and enable "Show Verbose output when... compiling". Then rerun the compile and copy/paste all the verbose compiler output (you'll have to do a bit of click-and-drag fussing around to select it all unfortunately, resizing the bottom pane will help, and then use Ctrl-C keyboard shortcut to Copy as the Arduino Edit->Copy won't work) and post that as well? It may be quite a lot of output so you may want to use a service like and just post a link.

Re: Cube4 Compiler Error/ Missing Driver /Windows8 / IDE 1.0

Posted: Thu Jun 27, 2013 9:12 am
by hamster

Here's a quick debugging flow for the CUBE4. I have had no problem with Arduino 1.5.2

The first thing is to check that the Cube4 library works....

* Open the Arduino GUI

* Under Tools/Board menu select "Arduino Leonardo"

* Check that you have the "Cube4" libaray listed in the "Sketch\Import Library" menu option. If not, then extract the files from the Cube4 zip file and add them into the Libraries directory in the Arduino directory. Exit the GUI, restart it and see if it now appears.

* First select "Sketch\Import Library\Cube4". This verifies that the Cube4 library is correctly installed.

Now to build a 'do nothing' sketch (you shouldn't have the Cube4 plugged in unless you want to nuke the self-test program....

* Select "File\New". You should have the default empty sketch open, about 9 lines in length

* Add the following two lines to the top, then click on the button to verify it:

Code: Select all

  #include <SPI.h>
  #include <Cube.h>
You should get a message like:

Code: Select all

  Binary sketch size: 12,626 bytes (of a 28,672 byte maximum) - 44% use
If this step fails to verify then you have a problem with the library installation.

Onwards! Now is the time to check that the driver is all working.

* Make sure that the Cube4 is not plugged in.

* See if any ports are available under the Tools/Serial Port option. It is most likely grayed out unless you have a physical serial port on your PC. Take note of what serial ports are installed.

* Plug in the Cube4. Wait a while for the drivers to load (if they are there)

* See if any new port is available under the Tools/Serial Port menu option. If so then your drivers are all in place and working fine. If the port is not available check in device manager. If there is an unknown device update the driver from the one in the Arduino software's driver directory. Unplug the Cube4, plug it back in and try again.

* Select the newly appeared port in the Tools/Serial Port menu

If this all works then you should be all good to go. Next open one of the demos - "SunnyDay" is as good as any - try uploading it!

Re: Cube4 Compiler Error/ Missing Driver /Windows8 / IDE 1.0

Posted: Sat Jun 29, 2013 10:23 am
by BiggusD
Hi ,
Thanks for all your help guys, Finally got it going!,i followed hampsters' step by step debug ( good job mate), and realised i didnt have the cube4 files installed in the right place, and also i was running it as a leostick( which i thought was right before reading hampsters post, the instructions led me in this direction a little!).
Anyway, all is good now, & all example sketches work correctly.
Thanks to you smart fellows. You guys definitely dont have any blood supply diversion problems like me! ..(just kidding)

Re: Cube4 Compiler Error/ Missing Driver /Windows8 / IDE 1.0

Posted: Sun Jun 30, 2013 5:17 am
by hamster
Great news!

Don't be too hard on yourself - when starting out it is very easy to hit a brick wall because of a little error/oversight. It is very common for instructions to be about how to do things when everything works correctly, not how to fix things when they are broken....

Re: Cube4 Compiler Error/ Missing Driver /Windows8 / IDE 1.0

Posted: Mon Jul 01, 2013 2:52 am
by BiggusD
Yes, thats quite true about instructions.
Thanks again for your help guys, im going to try a few projects with arduino so i might be calling back in to get bailed out again!

Re: Cube4 Compiler Error/ Missing Driver /Windows8 / IDE 1.0

Posted: Mon Jul 01, 2013 10:32 pm
by vero96
Hi guys,

Thanks to everyone for their help, I too followed hamster's instructions seems my libraries are a bit of a mess, that and the paths. When I transferred all my old examples/sketchbook material, I did so from a win 7 PC to a win 8 PC - using a Belkin transfer cable basically everything on the old pc to the new one. Then downloaded the IDE again 1.0.5 to the win 8 PC however the IDE ended up on a different path. Long story short after reading hamsters original reply I followed the first few steps plugged the Cube4 in and what do ya know it worked. Still I spent countless hours trying to resolve this issue and I'm not quite sure if my assumption is correct, so I will take angus's advice and post the verbose output to as soon as I can, if anyone's interested in looking at it, because it may help others avoid the mistake/s I made. One minute it was working fine the next - nothing........and that's the part that just does not make much sense.
Any way it's doing it's thing so that what matters.

Re: Cube4 Compiler Error/ Missing Driver /Windows8 / IDE 1.0

Posted: Mon Jul 01, 2013 10:45 pm
by angusgr
Thanks hamster for posting those excellent diagnosis steps. Glad you both got it working, vero96 and BD.

FWIW you can program the Cube as either a Leonardo or a LeoStick V2, it will work either way.

Re: Cube4 Compiler Error/ Missing Driver /Windows8 / IDE 1.0

Posted: Mon Jul 08, 2013 1:47 am
by vero96
Hi, Guys and Girls angus suggested I post the verbose output of the Cube4
so here is the output while "sunny day" compiles"

and here is the verbose output during upload

Hope this helps answer a previously asked question, I realize it has taken some time for me to get around to doing this.

Cheers, vero