ICSP then no USB

The "Eleven" is our Uno-equivalent Arduino-compatible board, but with a number of improvements including prototyping area, a mini-USB connector, LEDs mounted near the edge, and the D13 LED isolated using a FET. [Product page]
Post Reply
GraemeSPa
Posts: 15
Joined: Tue Sep 24, 2013 11:58 am
Contact:

ICSP then no USB

Post by GraemeSPa » Mon Feb 10, 2014 7:07 am

I had a look for similar post , but can't see one.

I built a minimal component board for a Atmega 328 MCU and fitted a 6 pin ICSP header for programming using a USBAsp. it worked , no problem. Then jsut for fun I tried programming my Eleven board with the USBAsp - again no problem, but when I tried to go back to the using the usual mini USB connector to upload sketches , I get "programmer not responding" message from the IDE. What have I broken and how do I fix it?

andrew
Freetronics Staff
Freetronics Staff
Posts: 978
Joined: Sun Jul 14, 2013 7:06 am
Location: Melbourne, Australia
Contact:

Re: ICSP then no USB

Post by andrew » Mon Feb 10, 2014 9:14 pm

When you upload sketches using the ICSP pins the Arduino bootloader is wiped from the microcontroller, as it isn't necessary - you're directly uploading the code to the MCU.

To get your Eleven back to normal, simply upload the bootloader to the Eleven using the Tools>Burn Bootloader option in the IDE, then upload your sketch as normal via the USB cable.

GraemeSPa
Posts: 15
Joined: Tue Sep 24, 2013 11:58 am
Contact:

Re: ICSP then no USB

Post by GraemeSPa » Sat Mar 15, 2014 8:55 am

it works. Why it didn't every other time i tried this, i don't know. you learn something every day, eh?

thanks......

andrew
Freetronics Staff
Freetronics Staff
Posts: 978
Joined: Sun Jul 14, 2013 7:06 am
Location: Melbourne, Australia
Contact:

Re: ICSP then no USB

Post by andrew » Sun Mar 16, 2014 9:24 pm

GraemeSPa wrote:it works. Why it didn't every other time i tried this, i don't know. you learn something every day, eh?

thanks......
No worries.
Sometimes life's like that :)

iSteve
Posts: 21
Joined: Tue Dec 04, 2012 4:08 am

Re: ICSP then no USB

Post by iSteve » Wed Jul 15, 2015 7:24 am

Ive got the same problem.

i can program with your USBASP but cant use the micro usb on the Eleven.

Any ideas??

andrew
Freetronics Staff
Freetronics Staff
Posts: 978
Joined: Sun Jul 14, 2013 7:06 am
Location: Melbourne, Australia
Contact:

Re: ICSP then no USB

Post by andrew » Sat Jul 18, 2015 7:38 am

iSteve wrote:Ive got the same problem.

i can program with your USBASP but cant use the micro usb on the Eleven.

Any ideas??
Try reflashing the bootloader (connect USBasp to ICSP pins and use "Tools>Programmer>USBasp" in IDE then "Tools>Burn Bootloader".

Post Reply