Page 1 of 2

Eleven not recognised as device under Win7 64bit

Posted: Thu Jan 23, 2014 4:48 am
by BlackPope
Hi,
I'm having similar problems to other users - I'm running Windows 7, 64bit and my Eleven (which has previously run well with Vista) is not being recognised when connected via USB.

Tools>Serial Port remains greyed out, and occasionally, after 5 minutes or so, the Eleven will briefly show up in Device Manager under USB Controllers as an Unknown Device, which I then can't install a driver for, following the usual procedures.

I have the FreetronicsUSB_v1_3 driver and the files which are mentioned as missing in other forums on the same topic (usbser.sys & mdmcpq.inf)

One thing I have notice is that when the USB is initially connected D13 LED begins very dim and grown to full brightness.

Thanks,
John

Re: Eleven not recognised as device under Win7 64bit

Posted: Thu Jan 23, 2014 5:26 am
by andrew
Is it possible for you to try another USB cable?

Re: Eleven not recognised as device under Win7 64bit

Posted: Thu Jan 23, 2014 7:02 am
by BlackPope
Thanks for the quick reply johnb,
I've tried many cables, and all USB ports, all with the same outcome.

I just used Windows' Device Manager>Action>Add legacy hardware to install the Freetronics driver (although I wasn't sure whether to choose 16U2 or 8U2 so I installed both), so I now have both options in Device Manager>Ports (COM & LPT).

One thing I've just seen - when the Eleven is recognised in Device Manager under USB Controllers as an Unknown Device, if I go to Device Properties the Device Status is:
Windows has stopped this device because it has reported problems. (Code 43)
Then as few seconds later the USB disconnection noise sounds and the device status changes to:
Currently, this hardware device is not connected to the computer. (Code 45)
To fix this problem, reconnect this hardware device to the computer.


This cycle now repeats.....

I've been playing with this problem for a few days and am really stuck,
I might try to connect it to a computer that is currently working with an Eleven, if I can find one, just to check that it's not the Eleven.

Thanks again for your help.

Re: Eleven not recognised as device under Win7 64bit

Posted: Thu Jan 23, 2014 7:06 am
by andrew
BlackPope wrote:Thanks for the quick reply johnb,
I've tried many cables, and all USB ports, all with the same outcome.

I just used Windows' Device Manager>Action>Add legacy hardware to install the Freetronics driver (although I wasn't sure whether to choose 16U2 or 8U2 so I installed both), so I now have both options in Device Manager>Ports (COM & LPT).

One thing I've just seen - when the Eleven is recognised in Device Manager under USB Controllers as an Unknown Device, if I go to Device Properties the Device Status is:
Windows has stopped this device because it has reported problems. (Code 43)
Then as few seconds later the USB disconnection noise sounds and the device status changes to:
Currently, this hardware device is not connected to the computer. (Code 45)
To fix this problem, reconnect this hardware device to the computer.


This cycle now repeats.....

I've been playing with this problem for a few days and am really stuck,
I might try to connect it to a computer that is currently working with an Eleven, if I can find one, just to check that it's not the Eleven.

Thanks again for your help.
Fair enough. If if doesn't work on another computer and you bought the Eleven from Jaycar they can replace it for you otherwise email support@freetronics.com for a replacement.

Re: Eleven not recognised as device under Win7 64bit

Posted: Thu Jan 23, 2014 11:27 pm
by BlackPope
Ok thanks, will do.
Now to find a computer to test it on.

Re: Eleven not recognised as device under Win7 64bit

Posted: Tue May 06, 2014 7:12 am
by nicw
I have found this issue on Win7 x64 bit too. Most other Uno's work fine, but the Freetronics one seems to do this often on many computers.

This is how I have fixed it every time.

Plug in your board and wait for Windows to begin it's driver installation process. After a few moments, the process will fail, despite its best efforts
Click on the Start Menu, and open up the Control Panel.
While in the Control Panel, navigate to System and Security. Next, click on System. Once the System window is up, open the Device Manager.
Look under Other Devices). You should see an entry named "Arduino UNO" or "Unkown device"
Right click on the entry and choose the "Update Driver Software" option.
Next, choose the "Browse my computer for Driver software" option.
Finally, navigate to and select the driver file named "arduino.inf", located in the "drivers" folder of the Arduino Software download. If you are using an old version of the IDE (1.0.3 or older), choose the Uno's driver file named "Arduino UNO.inf"
Windows will finish up the driver installation from there.

Re: Eleven not recognised as device under Win7 64bit

Posted: Tue May 06, 2014 7:31 am
by andrew
nicw wrote:I have found this issue on Win7 x64 bit too. Most other Uno's work fine, but the Freetronics one seems to do this often on many computers.
Please use the Freetronics .inf as detailed in our tutorial:
http://www.freetronics.com/pages/instal ... or-windows

Re: Eleven not recognised as device under Win7 64bit

Posted: Sun Sep 14, 2014 1:05 am
by Stuart
Hi,

Browsing through the forums I found this topic which relates to my current problem. I am having difficulty installing the Freetronics USB driver for my Eleven board. Last night I completed the instal on my Win 7 (64bit) machine and it registered in the Device Manager as a COM port device as expected.

I then tried the Arduino IDE but I had trouble loading firmware to the Eleven and eventually gave up. This morning I booted up the PC and tried to reconnect to my Eleven board. This time the Eleven was no longer recognized as a COM port device but rather as an "Unknown Device" device under Universal Serial Bus controllers. I have followed all the tips given in this forum but cannot resolve the problem. Would this indicate that I have a bad Eleven board?

Please advise.

Thanks,
Stuart

Re: Eleven not recognised as device under Win7 64bit

Posted: Sun Sep 14, 2014 1:58 am
by Stuart
I think I found the problem. It appears to be the way Windows Administrator privilages are configured on my PC. I tested with my note PC and had no problems configuring drivers and connecting with the IDE, returning to my desktop I found that even though I am an administrator I did not have full privaleges. I had a thing called "Admin Approval Mode" turned on, see http://helpdeskgeek.com/windows-7/turn- ... windows-7/.

This is a Windows security feature that is supposed to prevent unauthorized changes to the system. After I turned this off, the driver started working normally. Not sure why though!?

Re: Eleven not recognised as device under Win7 64bit

Posted: Mon Sep 22, 2014 12:02 am
by Roche,Patrick
After reading this post over the weekend, I wanted to test my brand new freetronic's "Eleven" (Purchased from Jaycar in the "freetronic's Experimenter's Kit") on my Windows 7 64 bit Ultimate edition as I have been using the "Eleven" on my Windows 8 Netbook.

Just finished Installation and Everything worked "A OK" uploaded & Compiled Blink.

You will find that windows will fail to find a driver or just cancel the driver search.

Download the correct driver from freetronics website.

http://www.freetronics.com/pages/instal ... B9kEWflrIU

Click start > devmgmt.msc

typing the above at the run prompt will work in windows XP, Vista, Win7 and Win8.1

This will display the Windows Device Manager windows on screen.

A Yellow ! Mark will be displayed against the item you need to select and right click to update the driver select the INF file from the driver files that you downloaded from freetronic's website.

That should be all that is required.

You should then be able to run the ARDUINO IDE.

I have written a win7 install guide if required.