Page 1 of 1

Eleven + ESP01 wifi sheild

Posted: Thu Jul 19, 2018 6:51 am
by karapoti
Hi there.

I've got ye olde eleven starters kit and am trying to make it work with the ESP01 Wifi sheild, and was hoping for some help... as I'm getting a sore head from bashing it on the key board for so long...

I've followed the tutorial: ... 1AzXtIzY-U

Modified the code in it so that it would compile:

Code: Select all

 * SerialReflector
#include <SoftwareSerial.h>
SoftwareSerial device(2,3); // Rx, Tx

void setup() {
  // put your setup code here, to run once:

  Serial.begin(115200); // Serial port for connection to host   
  device.begin(115200); // Serial port for connection to serial device

void loop() {
  // put your main code here, to run repeatedly:
    if(device.available())   {     
    if(Serial.available())   {     
But get the following errors:

Sketch uses 3118 bytes (9%) of program storage space. Maximum is 32256 bytes.
Global variables use 297 bytes (14%) of dynamic memory, leaving 1751 bytes for local variables. Maximum is 2048 bytes.
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xa2
avrdude: stk500_recv(): programmer is not responding

Tried setting the COM port to 115200, same same...
the jumper pins are in the right spots, and match the rx tx

anyone have any ideas that might help?



Re: Eleven + ESP01 wifi sheild

Posted: Thu Jul 19, 2018 7:18 am
by karapoti
update - I can upload to the board/sheild without the esp-01 wifi module plugged in.

me thinks the wifi module may be toast...

Re: Eleven + ESP01 wifi sheild

Posted: Mon Jul 23, 2018 4:08 am
by danieldewaard
Hi Karapoti,

Thanks for getting in touch with us.

Could you provide us with more details about what you have tried so far? What position are the jumpers on the shield in? By default the jumpers should be positions on D3 and D2, however if the jumpers are on D0 or D1 this will deactivate the USB connection to the Arduino when the ESP01 is plugged in.

It could also be possible that your ESP01 has shipped with different firmware than our shield has been designed for. Over time as the popularity of the ESP01 has increased, so has the variation in firmware and hardware claiming to be the ESP01. You could also try re-flashing the firmware on the module. The following tutorial should give you some guidance: ... 6-firmware