missing com port

A shrunk down Leonardo-compatible board, thumb drive sized with native USB support. [Product info]
Thor-Atle
Posts: 8
Joined: Sun Jun 03, 2012 8:15 am
Location: Bergen, Norway

missing com port

Post by Thor-Atle » Wed Jun 13, 2012 7:22 am

I have uploaded AnalogReadSerial to my LeoStick, but no comport is shown in Device manager.

User avatar
Lemming
Posts: 4
Joined: Wed Dec 14, 2011 2:48 am
Location: Brisbane, Australia.
Contact:

Re: missing com port

Post by Lemming » Wed Jun 13, 2012 7:39 am

Not 100% certain, I will check when I get home, but I believe mine doesn't appear with a serial port once loaded, it just appears as an "Arduino Leonardo"

Thor-Atle
Posts: 8
Joined: Sun Jun 03, 2012 8:15 am
Location: Bergen, Norway

Re: missing com port

Post by Thor-Atle » Fri Jun 15, 2012 8:29 am

I pressume my computer already have the right LeoStick driver, because the stick appears as Freetronics LeoStick (Com9) when reset. Is there anything missing in the AnalogReadSerial sketch?

Carnes
Posts: 21
Joined: Wed May 16, 2012 8:47 pm

Re: missing com port

Post by Carnes » Sat Jun 16, 2012 2:35 am

Thor-Atle wrote:I pressume my computer already have the right LeoStick driver, because the stick appears as Freetronics LeoStick (Com9) when reset. Is there anything missing in the AnalogReadSerial sketch?
Nope, it sounds like you've got everything correct : ) But the com port "disappears" after a few seconds after the reset and reappears as the leostick. This is why you have to press reset before re-uploading a sketch. Hope this helps

Thor-Atle
Posts: 8
Joined: Sun Jun 03, 2012 8:15 am
Location: Bergen, Norway

Re: missing com port

Post by Thor-Atle » Mon Jun 18, 2012 6:36 am

What about reference to any library with the functions needed? I pressume the functions serial. and analogRead need more information somewhere?

Carnes
Posts: 21
Joined: Wed May 16, 2012 8:47 pm

Re: missing com port

Post by Carnes » Tue Jun 19, 2012 12:51 am

Thor-Atle wrote:What about reference to any library with the functions needed? I pressume the functions serial. and analogRead need more information somewhere?
You mean how do they read from the com port if it closes? If there is a serial.begin in setup() then it seems to stay open. If not, it will close. Are you seeing this behavior as well?

Thor-Atle
Posts: 8
Joined: Sun Jun 03, 2012 8:15 am
Location: Bergen, Norway

Re: missing com port

Post by Thor-Atle » Tue Jun 19, 2012 8:16 am

Yes. When reset the LeoStick emerges as Freetronics Leostick (com7) for a few seconds, and then changes to Other devices, Arduino Leonardo. And then with a question mark on. Which I believe means driver is not installed correct. I try to update the driver on the Arduino Leonardo with pointing to the folder where the "LeoStick_Bootloader_Driver_v1.inf" is located, but Window reply with "Cannot install this Hardware. .. because the wizard cannot find the necessary software."

As I understand the AnalogRaedSerial I am supossed to receive a stream of numbers on a comport through the USB interface. Is that correct?

Carnes
Posts: 21
Joined: Wed May 16, 2012 8:47 pm

Re: missing com port

Post by Carnes » Tue Jun 19, 2012 11:00 pm

Ah ha, gotcha. This (to me) is normal behavior and everything is working properly :)

A way to test your serial stuff is go to File->Examples->Communication->SerialEvent and upload this to your device. Then open the Serial monitor (top right on the ide). Be sure to set the baud to 9600 and the line ending to "Newline". Type something and press enter, it should be echo'd back to you.

I'm testing this on a Duemilanove because my Leostick is permanently embedded in a project at work.

Thor-Atle
Posts: 8
Joined: Sun Jun 03, 2012 8:15 am
Location: Bergen, Norway

Re: missing com port

Post by Thor-Atle » Thu Jun 21, 2012 12:52 pm

It's not possible to use Serial Monitor against my LeoStick, because there is no com port associated with the stick. In Device manager I have a device called Arduino Leonardo, but no com port.

So my question is, how do I get my LeoStick to appear as a com port in device manager when I have uploaded AnalogReadSerial?

Carnes
Posts: 21
Joined: Wed May 16, 2012 8:47 pm

Re: missing com port

Post by Carnes » Thu Jun 21, 2012 11:32 pm

Thor-Atle wrote:It's not possible to use Serial Monitor against my LeoStick, because there is no com port associated with the stick. In Device manager I have a device called Arduino Leonardo, but no com port.

So my question is, how do I get my LeoStick to appear as a com port in device manager when I have uploaded AnalogReadSerial?
The com port will appear briefly after the Leostick is restarted and then disappear (unless something is holding it open). At a minimum, TRY what i said in the previous post. When you pop the Serial Monitor open it should force a reset too.

Post Reply