Drivers installed and sketches uploading however no serial monitor tried on multiple sketches

A shrunk down Leonardo-compatible board, thumb drive sized with native USB support. [Product info]
Post Reply
pleiksnal
Posts: 3
Joined: Fri Sep 25, 2015 3:22 am

Drivers installed and sketches uploading however no serial monitor tried on multiple sketches

Post by pleiksnal » Fri Sep 25, 2015 3:27 am

Hello,

I've installed all the freetronics drivers and some items such as the IMU program for 9DOF and a serial monitor test program upload fine. When I go to serial monitor however and set the baud corresponding to the program the monitor screen is blank.

As far as I know these programs don't require any input to start displaying serial.

Has anyone else had this problem?

Thanks
Levi Pleiksna

pleiksnal
Posts: 3
Joined: Fri Sep 25, 2015 3:22 am

Re: Drivers installed and sketches uploading however no serial monitor tried on multiple sketches

Post by pleiksnal » Fri Sep 25, 2015 3:28 am

Druid for arduino also doesn't work

angusgr
Freetronics Staff
Freetronics Staff
Posts: 853
Joined: Tue Apr 09, 2013 11:19 pm
Location: Melbourne, Australia
Contact:

Re: Drivers installed and sketches uploading however no serial monitor tried on multiple sketches

Post by angusgr » Fri Sep 25, 2015 5:52 am

Hi Levi,

That's an unusual problem, as the bootloader also requires serial communication so any fault with the serial should also prevent bootloader uploads.

I'm guessing you're on Windows. Is there any other software running that might be communicating with the serial port? Can you double-check the COM port number and the baud rate?


Angus

pleiksnal
Posts: 3
Joined: Fri Sep 25, 2015 3:22 am

Re: Drivers installed and sketches uploading however no serial monitor tried on multiple sketches

Post by pleiksnal » Fri Sep 25, 2015 7:14 am

I tested the leostick with maniacBug’s RF24 Library and the serial works when I type 'T' to put the device in transmit mode. Maybe theres a problem with my freetronics 9DOF ? I'm using the main code mentioned in getting started guide and just getting nothing at all.

Any ideas?

Thanks

angusgr
Freetronics Staff
Freetronics Staff
Posts: 853
Joined: Tue Apr 09, 2013 11:19 pm
Location: Melbourne, Australia
Contact:

Re: Drivers installed and sketches uploading however no serial monitor tried on multiple sketches

Post by angusgr » Mon Sep 28, 2015 6:28 am

You should get at least some output from the ArduinoIMU example when you run it. However it can be a problem to open the serial monitor quickly enough to see the first few lines.

Try editing the sketch and change this line:

Code: Select all

Serial.begin(SERIAL_PORT_SPEED);
to this:

Code: Select all

Serial.begin(SERIAL_PORT_SPEED);
while(Serial.available() == 0) { }
... then the sketch will pause on reset, until you open the Serial Monitor and send something (anything at all will do). Then you should see the output that normally comes immediately after reset. This will hopefully provide a clue as to why it's not working.


Angus

Post Reply