Leostick and AVR(Atmel) Studio 6

A shrunk down Leonardo-compatible board, thumb drive sized with native USB support. [Product info]
Post Reply
Joined:Sun Mar 24, 2013 9:30 pm
Leostick and AVR(Atmel) Studio 6

Post by Doogs » Mon Mar 25, 2013 11:09 am

Hi everyone,

Has anyone successfully gotten AVR Studio 6 to program their leostick?

I've tried quite a few ways to get AVR Studio 6 to program the Leostick, but I suspect the COM Port jumping around causes problems. COM10 for bootloader, COM12 for Program.

I've tried this: http://omarfrancisco.com/arduino-progra ... tudio-6-0/
and this: http://www.hilltop-cottage.info/blogs/adam/?p=211
I've also tried MegunoLink.

Using OSX Arduino IDE works Ok. Using VMWARE W_XP Arduino IDE works ok, I just can't work out how to 'sync' the COM port swapping.

If anyone has found a way to get it to work I would like to hear about it.

Joined:Wed Mar 04, 2015 12:49 am

Re: Leostick and AVR(Atmel) Studio 6

Post by graemet » Wed Mar 04, 2015 12:56 am


Did you ever get this resolved?

Freetronics Staff
Freetronics Staff
Joined:Tue Apr 09, 2013 11:19 pm
Location:Melbourne, Australia

Re: Leostick and AVR(Atmel) Studio 6

Post by angusgr » Thu Mar 05, 2015 12:25 am

I've programmed LeoSticks quite a bit on the command line with 'avrdude', which is probably not too different from Atmel Studio.

The bootloader COM port number is consistent, ie if resets as COM10 for the bootloader once then it should be COM10 each time it resets. So the technique I've settled on is to manually press reset, then run the upload process.

It's not quite as nice as the auto-reset you get with Arduino, but it should work.

Post Reply