LeoStick install and first time use - Windows

A shrunk down Leonardo-compatible board, thumb drive sized with native USB support. [Product info]
marc
Freetronics Staff
Freetronics Staff
Posts: 16
Joined: Sat Oct 15, 2011 12:54 pm

LeoStick install and first time use - Windows

Post by marc » Sat Feb 11, 2012 2:49 pm

LeoStick installation and first time use.Please check this out before plugging in your LeoStick for the first time, we keep known issues and workarounds here.
-------
Installation and setup on Windows:

LeoStick Windows USB Driver Installation:
http://www.freetronics.com/pages/leostick-usb-driver

LeoStick Getting Started Guide:
http://www.freetronics.com/pages/leosti ... rted-guide

geoffking65
Posts: 1
Joined: Wed Aug 01, 2012 2:01 am

Re: LeoStick install and first time use - Windows

Post by geoffking65 » Wed Aug 01, 2012 2:09 am

Thanks for the post.

Suggest for noobes there be a step by step getting started guide for the leoStick.

Would love a guide that goes frorm installing Driver, downloading IDE, config settings and running the blink project.

I have fumbled way through installing USB and Arduino IDE. I have told the IDE that I am COM3 and use a Arduino Leonardo. Compiling elicits a few flashes on the LeoStick then ends (after a long delay) and I get the following error message:

avrdude: ser_send(): write error: sorry no info avail.

Help!

Ziral
Posts: 2
Joined: Sat Aug 04, 2012 5:08 pm

Re: LeoStick install and first time use - Windows

Post by Ziral » Sat Aug 04, 2012 5:20 pm

I am having the same type of problem with my leostick. on both of my computers if I try to install a blink example to the board, the progress bar will hang up and never complete.

If I try to stop and retry the computer will say that the com port is busy until I reset the Arduino.

I was able to get the bard to complete an upload one time using a friends laptop running some version of Linux(I think Mint or Ubuntu).

However when I tried to load a sketch from my laptop using fedora17 or windows7 it created the same problem as with my desktop which runs windows7 as well.

Any advice would be appreciated.

crunners
Posts: 1
Joined: Thu Aug 09, 2012 4:54 am

Re: LeoStick install and first time use - Windows

Post by crunners » Thu Aug 09, 2012 4:59 am

I was getting similar errors on Windows 7, 64 bit,

I found that Arduino 1.0.1 does not have the leonardo entry in Boards.txt commented out.

But the values it has in several fields are different to the Leostick startup guide. In particular the protocol, upload speed and fuses.

so after setting them the same as the startup guide and hitting RESET just before the upload it worked correctly

Hope this Helps, Peter

GlennA
Posts: 1
Joined: Sun Aug 12, 2012 12:35 pm

Re: LeoStick install and first time use - Windows

Post by GlennA » Tue Aug 14, 2012 8:39 am

I'm having trouble loading the driver as per instructions. I downloaded ver1.01 of the IDE so need to use method 2 in instructions. In Device Manager 'FreeTronics LeoStick loader' isn't listed. Arduino Leonardo is listed instead. When I try to update the driver it wont find the driver (tried Windows7 64bit and Windows7 32bit computers). I get a message 'Windows was unable to install your Arduino Leonardo'. Any help appreciated.

GlennA

r23d
Posts: 6
Joined: Fri Aug 24, 2012 2:42 am

Re: LeoStick install and first time use - Windows

Post by r23d » Fri Aug 24, 2012 2:58 am

Hi GlennA - I have a similar issue with a driver install failure that I have yet to solve on a win7 64bit machine.

I downloaded the leostick inf, and installed the driver correctly at first as per the install guide page.

I then setup the hardware directory and set that up as per method 2.

So far so good.

I then loaded a sketch in arduino 1.01, selected the right serial port and the Freetronics leostick from the hardware menu dropdown.

All looking good.

But when I uploaded the sketch, I got some strange behaviour from the leostick - it appeared to reset and no longer be recognised by my computer as a leostick.

I then got a failed install popup for an arduino leonardo.

When I plug it in now, it thinks it's an Arduino Leonardo, and will not recognise the downloaded leostick .inf it used to install the correct drivers initially.

So I am basically now in the same position as you GlenA - A leostick that thinks it's Leonardo Davinci and won't install.

Will update with further progress, but meantime, can anyone else advise on the best way forward?

***EDIT*** It looks like this is expected behaviour - almost -

After jumping over from the usb driver install page to the "rest of the getting started guide" link, you need to go back to the usb driver page and keep reading. There it says after uploading your first sketch you will need to now install the leonardo drivers using the .inf located in the arduino ide directory.

Unfortunately for me, the leonardo.inf is not recognised for some reason, so I'm still stuck...

GlennA - see if installing the leonardo.inf from the arduino install dir works for you and let us know...

*EDIT 2* sorted.

You may need to force windows to recognise the .inf. When you are in the device manager, don't just browse to the directory the .inf is in and hope windows will play nicely, click the "let me pick from a list of device drivers on my computer" button then the "have disk" button, then browse to where leonardo.inf lives in the arduino install (look under \drivers) then select the leonardo. Works for me.

cheers, Richard

User avatar
jonoxer
Freetronics Staff
Freetronics Staff
Posts: 297
Joined: Sat Oct 15, 2011 11:31 am

Re: LeoStick install and first time use - Windows

Post by jonoxer » Wed Aug 29, 2012 12:21 pm

Replying here for the sake of people who may not have seen the follow-up in the other LeoStick thread. If you're still having trouble with LeoStick drivers, please see:

viewtopic.php?f=27&t=285&start=10#p3312
--
Jon

sunchunfor
Posts: 5
Joined: Fri Sep 07, 2012 6:23 am

Re: LeoStick install and first time use - Windows

Post by sunchunfor » Mon Sep 10, 2012 2:44 am

Hi Jonoxer,

After All, you still not answer the Question come from r23d and a lot of new LeoStick user.

I used the "Freetronics Eleven" since April. it is a very good and easy product. Thank you for provide a lot of fun in electronic world.

I saw this new product "LeoStick" and think that it will be the same. Unfortunately , this is a total different experience.

The major problem for us is the window XP (not sure other OS) think the LeoStick is a "Arduino Leonardo", and the window keep asking for the "Arduino Leonardo" driver.
So far, I read the forum for 5 days. I can't see any easy solution. and I still can't make use of this "LeoStick"

If there is no easy solution, the "freetronics" company should recall the product. Your company better keep its good name in the market than have this product that kill the thrust of the company.

After all, I still want your company can provide a good solution on this "LeoStrick". If this work, it will be a good arduino board.

Thanks you

Regards

User avatar
jonoxer
Freetronics Staff
Freetronics Staff
Posts: 297
Joined: Sat Oct 15, 2011 11:31 am

Re: LeoStick install and first time use - Windows

Post by jonoxer » Mon Sep 10, 2012 3:28 am

sunchunfor wrote:The major problem for us is the window XP (not sure other OS) think the LeoStick is a "Arduino Leonardo", and the window keep asking for the "Arduino Leonardo" driver.
It's unfortunate that the LeoStick (and in fact all Arduino Leonardo compatible boards) have to work this way, but it's expected behaviour. It's mentioned in bold text at the bottom of the .inf installation guide:

http://www.freetronics.com/leostick-usb-driver

The basic issue is that sketches loaded onto the board have their own USB ID embedded within them by the Arduino IDE, and it's totally beyond our control. The bootloader on the board has our own officially registered ID (which matches the settings in the .inf file) but once a sketch is loaded by the IDE it reports its own ID as if it's a Leonardo, so you need the Leonardo .inf file loaded as well as our .inf.
--
Jon

sunchunfor
Posts: 5
Joined: Fri Sep 07, 2012 6:23 am

Re: LeoStick install and first time use - Windows

Post by sunchunfor » Tue Sep 11, 2012 4:05 am

Hi,

thanks for you help, but I still have the same problem.

I follow the installation guide in bold text at the bottom part.
firstly, I get the "computer Management" screen.
in "other devices" I get a question mark in "Arduino Leonardo"

I right click it and select "update driver". and pointed to the below directory
"C:\Program Files\arduino-1.0.1\drivers" which have the file "Arduino Leonardo.inf"

I get the error is "cannot install this hardware"

Regards

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests