Dark LED - but it's glowing

The Dot Matrix Display (DMD) is a 32x16 array of high-brightness LEDs for visually striking effects. [Product Page]
Post Reply
rav
Posts:2
Joined:Wed May 14, 2014 5:13 pm
Dark LED - but it's glowing

Post by rav » Wed May 14, 2014 5:29 pm

I connected one DMD to a Arduino Nano, loaded the Demo-Programm and it works.

But:

"Dark" LED (Pixels) are glowing (=not completely off) and this makes difficult to read the de text, etc. Even with an external power supply (5V): The brightness increases but event the glowing LEDs.

dmd.clearScreen( true ) makes the display really dark.

Any help is appreciated.

andrew
Freetronics Staff
Freetronics Staff
Posts:978
Joined:Sun Jul 14, 2013 7:06 am
Location:Melbourne, Australia
Contact:

Re: Dark LED - but it's glowing

Post by andrew » Wed May 14, 2014 11:06 pm

Is there any chance you can test the DMD using an Arduino Uno or compatible?
Then we can isolate the fault to either the DMD or something else?
In the meanwhile, double-check your wiring for accuracy and good connections (i.e. soldered etc.)

Brissieboy
Posts:209
Joined:Fri Sep 20, 2013 7:25 am

Re: Dark LED - but it's glowing

Post by Brissieboy » Thu May 15, 2014 3:44 am

rav,

A possible clue, maybe.
If you are getting the correct characters displayed on the DMD, it means that most of your connections are correct data (R), clocking (SCLK, SCK), and block decoding (A, B). It sounds like the output enable (D9) might be the culprit. This one blanks the display briefly during the block select and output latching part of the DMD data update process. If it is not working properly you will get erroneous displays, and they will be dim because they are only on very briefly.

rav
Posts:2
Joined:Wed May 14, 2014 5:13 pm

Re: Dark LED - but it's glowing

Post by rav » Thu May 15, 2014 5:37 pm

Thank you for the fast feedback.
Actually I do only have a "Leonardo" and two "Nano" available. I know, that the "Leonardo" can not be used for dem DMD.
But I tried the second Nano, also tried with a different cabling (breadboard). The behavior is all time the same: "glowing" dark LED.

andrew
Freetronics Staff
Freetronics Staff
Posts:978
Joined:Sun Jul 14, 2013 7:06 am
Location:Melbourne, Australia
Contact:

Re: Dark LED - but it's glowing

Post by andrew » Thu May 15, 2014 11:27 pm

rav wrote:Thank you for the fast feedback.
Actually I do only have a "Leonardo" and two "Nano" available. I know, that the "Leonardo" can not be used for dem DMD.
But I tried the second Nano, also tried with a different cabling (breadboard). The behavior is all time the same: "glowing" dark LED.
You may have a faulty DMD. Please email support@freetronics.com.

Post Reply