Can't Program using USBasp

Our range of tiny modules are designed to make it easy for you to quickly add functionality to your projects. [Module List]
Post Reply
Joined:Mon Oct 07, 2013 4:08 am
Can't Program using USBasp

Post by DannyV » Thu Feb 02, 2017 7:52 am

Hi Folks,
(Further to my recent emails to/from Daniel).

I cannot program my EtherMega2560s, nor EtherTen with the USBasp interface from Freetronics.

This all started when I got down to the bottom to my pile of EtherMega's R3 V3.0 and my remaining ones have 'broken' USB comms.
I have programmed around 12 or more of these boards in many different formats, all via the USB port. But when I tried to
Program using my USBasp, the Mega seemed to lock up. After much testing, it proved that I couldn't program with even the
simplest sketch.

Here is my setup:
Mac OS X 10.11.6 (El Capitan) - All the latest updates including Xcode & Online Utilities, & HomeBrew.
Windows 7 Virtual machine running on the Mac.
Arduino 1.8.1 (and 1.8.2 daily build tried also) after completely stripping all traces of old versions and settings.
(Same version installed on Windows Virtual Machine, & drivers)

I found on all boards, that I could use 'Burn Bootloader' successfully, which installed blink, on Mac & Win,
and the LED blinked nicely 1/ sec.

But when I tried to install the Blink example, (or ANY sketch) it reported no warnings (set to 'W-all') or errors,
but the LED didn't blink (it was either off or on - and stayed that way) - it seemed sensitive to touch on the bottom of the board (even the new board).

I tried on Windows and Mac
I tried in 'Slow Mode'
I tried it powered by 12v, and by the USBasp.
I purchased a new USBasp board from Jaycar, and a new EthaMega2560 from TronixLabs - I could program the new Mega
normally, but not with the USBasp (I noticed after trying with the USBasp, I had to 'Burn Bootloader' again before I
could program it via the normal USB port).

I tried using LED_BUILTIN and pin 13 (the correct pin)
I also tried using millis() instead of delay()

Here's the blink code only slightly modified:

Code: Select all

uint8_t const  LEDPIN = 13;

// the setup function runs once when you press reset or power the board
void setup() {
  // initialize digital pin LED_BUILTIN as an output.
  //   pinMode(LED_BUILTIN, OUTPUT);
  //   digitalWrite(LED_BUILTIN, LOW);
  pinMode(LEDPIN, OUTPUT);
  digitalWrite(LEDPIN, LOW);

// the loop function runs over and over again forever
void loop() {
  //digitalWrite(LED_BUILTIN, HIGH);   // turn the LED on (HIGH is the voltage level)
  digitalWrite(LEDPIN, HIGH);   // turn the LED on (HIGH is the voltage level)
  delay(1000);                       // wait for a second
  //digitalWrite(LED_BUILTIN, LOW);    // turn the LED off by making the voltage LOW
  digitalWrite(LEDPIN, LOW);    // turn the LED off by making the voltage LOW
  delay(1000);                       // wait for a second
Has anyone got ANY ideas about this please?


Joined:Thu Jan 18, 2018 1:08 pm

Re: Can't Program using USBasp

Post by cook_with_sun » Thu Jan 18, 2018 1:18 pm

I am new to this forum.
I have the same problem with my USBASP ICSP.
Seems you never received any support from Freetronics stuff.
How can I continue?
Greetings from Austia.

Post Reply