Search found 5 matches

by nickwest
Sun Sep 10, 2017 7:14 am
Forum: OLED128 Display
Topic: Any issues running it off 3.3V?
Replies: 0
Views: 36

Any issues running it off 3.3V?

According to the product page, this board will run off 3.3v. Has anyone tried it? Are there any pitfalls I should be aware of?

Thanks!
by nickwest
Sat Dec 10, 2016 7:56 pm
Forum: OLED128 Display
Topic: corrupted display - signal noise?
Replies: 2
Views: 2801

Re: corrupted display - signal noise?

After some more testing, it looks like I was having a problem with using up RAM. I was using the example code to display a .BMP. It looks like the issue is with this part: BMP_Status result = oled.displayBMP(image, 0, 0); if(result != BMP_OK) { Serial.print("Error loading BMP "); Serial.println((int...
by nickwest
Sun Oct 09, 2016 11:17 am
Forum: OLED128 Display
Topic: Wiring to Bluz
Replies: 2
Views: 1612

Re: Wiring to Bluz

I think I understand what you mean - using the ICSP port is the same as wiring to PINs. The ICSP port on Arduinos is connected directly to the normal pins on the Arduino and they share the SPI bus. Have a look at the schematic at https://www.arduino.cc/en/uploads/Main/arduino-uno-schematic.pdf to sh...
by nickwest
Thu Oct 06, 2016 9:03 pm
Forum: OLED128 Display
Topic: corrupted display - signal noise?
Replies: 2
Views: 2801

Re: corrupted display - signal noise?

Nobody has ever seen this problem before? Any suggestions? I can't see any pattern to the issue - the number of frames I get before the image corruption and eventual freezing doesn't seem consistent. I'll try sending simple data straight from the arduino to the screen, to see if taking the SD card r...
by nickwest
Thu Sep 15, 2016 1:40 pm
Forum: OLED128 Display
Topic: corrupted display - signal noise?
Replies: 2
Views: 2801

corrupted display - signal noise?

Hi all, I see these bands of coloured "static" at the tops of my images when I display .BMPs. I'm updating the display about every second or so, and the first few updates are fine, then the noise appears, then a couple of frames later the arduino+screen hangs on the noisy image and has to be reset. ...