Search found 9 matches

by mcmenon
Thu Jul 14, 2016 2:44 am
Forum: ES: Ethernet Shield
Topic: Unable to upload Sketch via Ethernet.
Replies: 2
Views: 4903

Re: Unable to upload Sketch via Ethernet.

Found my error: windows firewall was blocking tftp. Added an exception for this and it's working.
by mcmenon
Thu Jul 14, 2016 2:43 am
Forum: EtherTen
Topic: trouble with arduino-tftpboot, no pin 9 blink
Replies: 10
Views: 5967

Re: trouble with arduino-tftpboot, no pin 9 blink

I think I've solved it. Pin 9 is a red herring, sort of. I never got it to blink, but I was able to get code to bootload successfully via ethernet.

The very last piece of the puzzle: windows firewall was blocking tftp. Added an exception for that and it works now!
by mcmenon
Thu Jul 14, 2016 12:46 am
Forum: ES: Ethernet Shield
Topic: Unable to upload Sketch via Ethernet.
Replies: 2
Views: 4903

Re: Unable to upload Sketch via Ethernet.

I am having the same error. Trying to follow this process: http://www.freetronics.com.au/pages/how-to-upload-a-sketch-to-your-arduino-via-a-network#.V4be_JMrLBI Earlier, I noticed that pin 9 led was not flashing when the bootloader was supposedly burned. I'm not sure if this means the bootloader nev...
by mcmenon
Thu Jul 14, 2016 12:42 am
Forum: EtherTen
Topic: trouble with arduino-tftpboot, no pin 9 blink
Replies: 10
Views: 5967

Re: trouble with arduino-tftpboot, no pin 9 blink

Further information: I moved on from that point and I was able to - get IDE to tell me I had burned bootloader - upload code to set network settings - get IDE to once again tell me I had burned bootloader - connect to the arduino via ethernet at the network settings I previously set This suggests to...
by mcmenon
Wed Jul 13, 2016 10:37 pm
Forum: EtherTen
Topic: trouble with arduino-tftpboot, no pin 9 blink
Replies: 10
Views: 5967

Re: trouble with arduino-tftpboot, no pin 9 blink

I am stuck at the same point melias seemed to be before he disappeared. I am able to use my programmer to flash programs to the arduino. I am able to get the IDE to claim that it has successfully burned the bootloader. I know that pin 9 is functional and drives enough current to light up the LED. Ho...
by mcmenon
Wed Jul 13, 2016 7:05 pm
Forum: Random Chit-Chat
Topic: Error encountered when trying to upload sketch via ethernet
Replies: 2
Views: 2382

Re: Error encountered when trying to upload sketch via ethernet

Solved this problem

Apparently my .elf file was corrupted. I restarted everything and re-ran the verification from the IDE and created a new ELF file - this worked.
by mcmenon
Wed Jul 13, 2016 7:03 pm
Forum: EtherTen
Topic: Problem installing tftp boot package
Replies: 11
Views: 9118

Re: Problem installing tftp boot package

I solved this problem by installing an earlier version of arduino. I used version 1.0.5-r2 and the folder structure was as shown in the guide.
by mcmenon
Wed Jul 13, 2016 12:52 am
Forum: Random Chit-Chat
Topic: Error encountered when trying to upload sketch via ethernet
Replies: 2
Views: 2382

Re: Error encountered when trying to upload sketch via ethernet

I'm experiencing exactly the same problem - did you ever figure this out? I've tried a few things - downloading an up to date version of gcc tools from atmel (instead of what came with my old arduino version) - adding / removing commands such at -j, -I - indicating the .elf file was elf32, elf-littl...
by mcmenon
Thu Jul 07, 2016 10:43 pm
Forum: EtherTen
Topic: Problem installing tftp boot package
Replies: 11
Views: 9118

Re: Problem installing tftp boot package

I realize it's been a year since anyone posted on this topic, but... I was able to get the board to show up in my boards file by coping my boards.txt file from its original location (arduino-tftpboot) to a new location (arduino-tftpboot/bootloaders). However, even though the board shows up, I'm not ...